Написать программу,которая проверяет,есть ли во введённом с клавиатуры массиве элементы с одинаковым значением

elenasypchenkop00npz elenasypchenkop00npz    3   20.08.2019 11:00    2

Ответы
Largo2000 Largo2000  26.08.2020 07:27
// PascalABC.NET 3.2, сборка 1379 от 21.01.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ReadArrInteger('Вводите:',ReadInteger('n='));
  if a.Count>a.ToHashSet.Count then
    Writeln('Есть одинаковые элементы')
  else Writeln('Все элементы различны')
end.

Примеры
n= 4
Вводите: 4 2 5 2
Есть одинаковые элементы

n= 4
Вводите: 5 8 -3 0
Все элементы различны
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика