Написать программу которая по трём сторонам треугольника определяло бы, является треугольник равнобедренным.

albinatoleuhaa albinatoleuhaa    1   13.07.2019 12:30    0

Ответы
karkavina85 karkavina85  03.10.2020 02:55
Вот решение вашей задачи
ПОКАЗАТЬ ОТВЕТЫ
Цыпленочка Цыпленочка  03.10.2020 02:55
C++
#include <iostream>
using namespace std;
int main()
{
  int a, b,c;
  cout<<"Input 1-st number: "; cin>>a;
  cout<<"Input 2-st number: "; cin>>b;
  cout<<"Input 3-st number: "; cin>>c;
  if((a+b)<c || (a+c)<b || (b+c)<a){
    cout<<"Треугольник не существует"<<endl;
    return 0;
  }
  if(a==b || a==c || b==c)
   cout<<"Равнобедренный"<<endl;
  else
   cout<<"Он не равнобедренный"<<endl;
  return 0;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика