Написать программу, которая печатает введенное слово, начиная с последней буквы c++

cot579 cot579    2   25.08.2019 07:20    0

Ответы
спасибо84 спасибо84  05.10.2020 18:16
#include <iostream> 

void RevStr(char* S,int l)
{  
   char c;  
   if (l > 1)  
   {      
      c=S[0];      
      S[0]=S[l-1];      
      S[l-1]=c;      
      RevStr(S+1,l-2);    
   }
}  

int main(int argc, char* argv[])
{    
   char S[12]="Test of pen";       
   RevStr(S,11);    
   std::cout << S << std::endl;    
   return 0;
}
ПОКАЗАТЬ ОТВЕТЫ
Finikotik Finikotik  05.10.2020 18:16
#include
#include
using namespace std;
string s;
int main ()
{
cin >> s;
reverse (s.begin(), s.end());
cout << s;
return 0;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика