Написать программу, которая определяет максимум, минимум и среднее трех чисел. Числа ввести с клавиатуры.

великан007 великан007    3   01.02.2021 20:01    1

Ответы
МарияМяуМяу МарияМяуМяу  03.03.2021 20:02

program a1;

Var

a,b,c,max,min:integer;

Begin

Readln(a,b,c);

if (a = b) or (a = c) or (b = c) or ((a = b) and (b = c)) then

writeln('Ошибка, числа должны быть разными');

if (a>b) and (a>c) then max:=a;

if (b>a) and (b>c) then max:=b;

if (c>a) and (c>b) then max:=c;

if (a<b) and (a<c) then min:=a;

if (b<a) and (b<c) then min:=b;

if (c<a) and (c<b) then min:=c;

Writeln('Max:', max, ' Min:', min);

write('Среднее арифметическое:',(a+b+c)/3);

end.


Написать программу, которая определяет максимум, минимум и среднее трех чисел. Числа ввести с клавиа
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика