Написать программу, которая определяет, каким днем (рабочий день, суббота, воскресенье) является введенный номер дня недели. в теранарном операторе, как делать?

shedis2004 shedis2004    2   13.09.2019 10:40    1

Ответы
ovsjannikova20p01gvg ovsjannikova20p01gvg  07.10.2020 11:42
Не "теранарный", а тернарный оператор.
Есть во многих языках программирования, зря не указали, какой Вам надо.

// PascalABC.NET 3.3, сборка 1590 от 03.12.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger('День недели (1- Пн, 2- Вт, ... 7- Вс:');
  Writeln(n<6?'Рабочий день':n=6?'Суббота':'Воскресенье')
end.

Примеры (предполагается без проверки корректность ввода)
День недели (1- Пн, 2- Вт, ... 7- Вс: 4
Рабочий день

День недели (1- Пн, 2- Вт, ... 7- Вс: 6
Суббота

День недели (1- Пн, 2- Вт, ... 7- Вс: 7
Воскресенье
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика