Написать программу которая находит сумму и произведение чисел от 5 до 50 с шагом 5

АняГоловко0208 АняГоловко0208    3   18.07.2019 21:40    0

Ответы
295f9gh 295f9gh  30.08.2020 20:00
Var sum,pro,i:integer;
begin
    i:=5;
    sum:=0;
    pro:=1;
    while i<=50 do begin
        sum:=sum+i;
        pro:=pro*5;
        i:=i+5;
   end;
   writeln('Сумма = ',sum,', Произведение = ',pro); 
end.
ПОКАЗАТЬ ОТВЕТЫ
georgyudin2005 georgyudin2005  30.08.2020 20:00
Var s,p : BigInteger;
  i : Integer;
Begin
  p:=1; s:=0;
  For i:=1 to 10 do
  Begin
    s:=s+i*5;
   p:=p*i*5;
  end;
  Writeln('Сумма: ',s);
  Writeln('Произведение: ',p);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика