Написать программу, которая добавляет пробелы в строку.(то есть: если в тексте есть знак препинания «.», «,», «! » или «? », и после отсутствует пробел)

binfather binfather    1   04.06.2019 03:00    3

Ответы
0Jocker0 0Jocker0  01.10.2020 19:10
Var
  s1,s2:string;
  i,k:integer;
begin
readln(s1);
k:=length(s1)-1;
s2:='';
for i:=1 to k do
  begin
    s2:=s2+s1[i];
    case s1[i] of
      '.',',','!','?':
        if s1[i+1]<>' ' then s2:=s2+' ';
    end;
  end;
s2:=s2+s1[k+1];
writeln(s2)
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика