Написать программу, которая для случайно введенных с клавиатуры числе а, в, с выполняет действия: а) четные числа делит на 2 и результат выводит на экран б) нечетные числа выводит на экран без изменений
Var a,b,c:integer; begin read(a,b,c); if odd(a) then write(a,' ') else write(a/2,' '); if odd(b) then write(b,' ') else write(b/2,' '); if odd(c) then write(c,' ') else write(c/2,' '); end.
begin
read(a,b,c);
if odd(a) then write(a,' ')
else write(a/2,' ');
if odd(b) then write(b,' ')
else write(b/2,' ');
if odd(c) then write(c,' ')
else write(c/2,' ');
end.