Написать программу которая даст таблицу q5*5. каждый эелемент таблицы случайное число из отрезка [-30,+30]. вычислить сумму все отрицательных и сумму положительных элементов.

sheramedi sheramedi    1   28.03.2019 07:30    3

Ответы
Самозванко Самозванко  26.05.2020 22:51

var a,b,i,j,p,o: integer;
z:real;
m:array[0..31,0..31] of integer;
begin
randomize;
for i:=1 to 5 do
for j:=1 to 5 do
begin
z:=random;
b:=random(31);
if z<0.5 then m[i,j]:=b;
if z>0.5 then m[i,j]:=-b;
end;
for i:=1 to 5 do
for j:=1 to 5 do
begin
if m[i,j]>0 then p:=p+m[i,j];
if m[i,j]<0 then o:=o+m[i,j];
end;
write(p,' ',o);
end.

 

мда. подумать над задачкой пришлось немного) но вот результат)

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика