tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Написать программу.известно,что
Написать программу.известно,что x кг конфет - стоит a рублей.определить сколько стоит y кг этих же конфет,а так же сколько кг конфет можно купить на k рублей.все значения вводит пользователь
Ванёк20061
1 18.07.2019 19:50
7
Ответы
ervinbek2005
07.08.2020 09:47
Program konfeta;
uses crt;
var a,b,c,k:integer;
d,e,m:real;
begin
clrscr;
write('Input (x) weight: ');
readln(b);
write('Input (a) cost: ');
readln(a);
d:=a/b;
write('1 kg cost ',d:2:2);
writeln;
write('Input (y)kg: ');
readln(c);
e:=c*d;
writeln(c ,' kg cost= ',e:2:2);
write('Input k rub: ');
readln(k);
m:=k/d;
writeln(k ,' rub cost ',m:2:2 ,' kg.');
write('Press any key...');
repeat until
keypressed;
end.
если надо пояснение пиши
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
gulya19860630
06.10.2019 04:03
Найдите сумму чисел от 1 до 5 в паскале...
Оаоагигвшпоа
06.10.2019 04:10
Составьте программу, определяющую,относится ли введённых с клавиатуры год к первому веку первый век начинается 2001 г. и заканчивается в 2100...
дильназ152
06.10.2019 01:36
Чем список отличается от массива? от хеш-таблицы?...
guzelmuzepova
06.10.2019 04:10
На отрезке (-3.14; 3.14) с шагом 0,2 протабулировать функцию sin^2(x)+cos^2(x) в excel...
ДевочКаНауКи
31.05.2019 08:00
Кодирование данных двоичным кодом 27, 39,54,148,192,256,437 всё делим на 2....
dalakoff
21.09.2019 11:00
Гномы нашли яблоко весом 300 грамм. каждый гном откусывал часть яблока, составляющую 3% от веса имеющегося яблока. сколько гномов съедят половину яблока? каков будет вес...
am5673
21.09.2019 11:00
Напишите программу , которая по двум данным числам [ a,b] ( включая концы отрезка) программа получает на вход два натуральных числа a и b . программа должна вывести одно...
polina200412
08.06.2019 05:00
1. какой потребуется объём памяти, если необходимо разместить 2048 страниц текста в памяти этого накопителя (на странице размещается 64 строк по 128 символов в каждой строке)?...
Roman2321
23.02.2021 09:38
Помагите с задание в Small Basic. 1. Определить и вывести на экран сумму элементов в каждой строке. Определить строку с максимальным значением этой суммы и вывести ее номер...
Diannata
17.04.2019 05:10
Вспомните, какие достижения и проблемы достались в «наследство» Брежневу и всему советскому руководству от эпохи правления Хрущёва...
Популярные вопросы
[обобщающее слово: o,o] предложение...
3
Чи можна вважати оцет чистою речовиною...
2
Розрахуйте масу води та 96%-ної сульфатної кислоти які необхідно взяти...
3
Какой по составу должна быть ткань для следующих изделий? • летнее платье...
3
Мемлекеттік тілдің қазыргі аясы сіздің көңіліңізден шыға ма?...
1
Начертить прямую cd. отметить точку,лежащую на этой прямой,и точку,не...
3
1. купили в магазине цыпленка,принесли домой и назвали цыпом. предложение...
2
Решите уравнение 6sin x - sin x = 1...
2
Кто может решить и объяснить как это решить (a+6)²-2a(3-2a)?...
3
Определите, какова цена деления каждого из измерительных приборов, изображенных...
1
uses crt;
var a,b,c,k:integer;
d,e,m:real;
begin
clrscr;
write('Input (x) weight: ');
readln(b);
write('Input (a) cost: ');
readln(a);
d:=a/b;
write('1 kg cost ',d:2:2);
writeln;
write('Input (y)kg: ');
readln(c);
e:=c*d;
writeln(c ,' kg cost= ',e:2:2);
write('Input k rub: ');
readln(k);
m:=k/d;
writeln(k ,' rub cost ',m:2:2 ,' kg.');
write('Press any key...');
repeat until
keypressed;
end.
если надо пояснение пиши