tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Написать программу используя процедуру
Написать программу используя процедуру которая сортирует элементы целочисленного массива b[1..n],n меньше или равно 25 по убыванию
rusikov972
1 30.07.2019 05:40
0
Ответы
DaryaAminina
27.09.2020 19:18
Class Sort25{
public static void main(String[] args) throws java.io.IOException{
int c, n = 0, array[];
while((c = System.in.read())==13 || (47<c && c<58 && (n = n*10+c-48)>-1));
if(25<n || c!=10)return;
array = new int[n];
for(c = 0; c<n; c++){
int d = 0; boolean negative = false;
while((d = System.in.read())!=10)
if(47<d && d<58)array[c] = array[c]*10+d-48;
else if(d==45)negative = true;
if(negative)array[c]*=-1;
}
sortArray(array);
for(c = 0; c<n; c++)System.out.print(array[c]+" ");
}
private static void sortArray(int[] array){
for(int c = 0; c<array.length-1; c++){
int b = c, e;
for(int d = c+1; d<array.length; d++)
if(array[d]>array[b])b=d;
e = array[c];
array[c] = array[b];
array[b] = e;
}
}
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
sanik98
25.08.2020 18:40
Количество различных элементов — 2 Дан список. Посчитайте, сколько в нём различных элементов, не изменяя самого списка. Входные данные Вводится список чисел. Все числа...
Саня130905
25.08.2020 18:19
С++. Написать программу, чтобы получить информацию о разделах жесткого диска, и о самом жестком диске...
синегривка2
17.05.2019 03:48
Сообщение, объемом 450 битов состоит из 150 символов. какова мощность алфавита?...
BlazeySpace01
17.05.2019 03:54
Выберите определение для понятия линейный алгоритм 1)линейный алгоритм - это алгоритм, в котором выполняются определенные команды 2)линейный алгоритм - это алгоритм,...
ангел81433
17.05.2019 02:03
Понятие модели материальных и нематериальных моделей эссе написать информатика...
Marys67
17.05.2019 02:49
Составить программу вычисления в паскале...
Anya183930303
19.12.2020 19:44
СДЕЛАЙТЕ ТАКУЮ ТАБЛИЦУ В EXCEL Отправить файл можно тут...
velikayadasha
19.12.2020 19:42
В электронной таблице выделены 15 ячеек, расположенных в столбце F, начиная со строки 7. Запишите адрес выделенного диапазона....
ilia39loh
19.12.2020 19:41
В какой вкладке выполняются настройки Панели быстрого доступа и Автосохранения?...
ksenaf
19.12.2020 19:40
Здравствуйте с информатикой, нужно решить задачу, связанной с базами данных...
Популярные вопросы
You must have a rest your classes. (in / after ) the teacher will...
3
Напишите ур-е реакции гидролиза глюкозы на никелевом катализаторе....
2
А) (3,5-x)*6=1,2 б) 4,2*(x-4,5)=16,38...
2
Найдите абсолютную величину вектора а ( 3; 4 )...
3
Нужен короткий текст на тему государственные символы казахстана...
2
Высота равностороннего треугольника равна 15√3 .найдите его периметр....
3
Запишите формулу перимитра прямоугольника со сторонами a и b.вычеслите...
3
Nano3- hno3 рассмотрите как окислительно-восстановительную....
1
Реши арифметически двумя в книге 128 страниц. юра прочитал 7/8...
3
Выбери а) число которое состоит из трёх сотен и восьми десятком...
3
public static void main(String[] args) throws java.io.IOException{
int c, n = 0, array[];
while((c = System.in.read())==13 || (47<c && c<58 && (n = n*10+c-48)>-1));
if(25<n || c!=10)return;
array = new int[n];
for(c = 0; c<n; c++){
int d = 0; boolean negative = false;
while((d = System.in.read())!=10)
if(47<d && d<58)array[c] = array[c]*10+d-48;
else if(d==45)negative = true;
if(negative)array[c]*=-1;
}
sortArray(array);
for(c = 0; c<n; c++)System.out.print(array[c]+" ");
}
private static void sortArray(int[] array){
for(int c = 0; c<array.length-1; c++){
int b = c, e;
for(int d = c+1; d<array.length; d++)
if(array[d]>array[b])b=d;
e = array[c];
array[c] = array[b];
array[b] = e;
}
}
}