Написать программу для вычисления дискриминанта d квадратного уравнения ax2 + bx + c = 0. разработать тесты проверки правильности работы программы для вариантов, когда d> 0, d=0 и d< 0.
var a,b,c,d:integer; x1,x2:real; begin writeln('Введите коэффициенты'); readln(a,b,c); d:=b*b-4*a*c; if (d<0) then writeln('Нет решения') else if (d=0) then begin x1:=-b/(2*a); writeln('x=',x1); end else begin x1:=(-b+sqrt(d))/(2*a); x2:=(-b-sqrt(d))/(2*a); writeln('x1= ',x1,'x2=',x2); end;
Выложу решение полного уровнения.
var a,b,c,d:integer; x1,x2:real;
begin
writeln('Введите коэффициенты');
readln(a,b,c);
d:=b*b-4*a*c;
if (d<0) then writeln('Нет решения')
else if (d=0) then
begin
x1:=-b/(2*a);
writeln('x=',x1);
end
else begin
x1:=(-b+sqrt(d))/(2*a);
x2:=(-b-sqrt(d))/(2*a);
writeln('x1= ',x1,'x2=',x2);
end;
readln
end.