Написать программу для подсчета количества если индекс ячейки нечетное , а элемент ячейки -четно 5 ;-3;6;1;0;3;17;2;8;9
!

gnastasiya5 gnastasiya5    2   13.04.2021 15:44    3

Ответы
diankapermyakoowxdr6 diankapermyakoowxdr6  13.05.2021 15:45

Var

i,n:integer;

a:array[1..20]of integer;

begin

writeln('Исходный массив:');

for i:=1 to 20 do

begin

a[i]:=random(10);

if (i mod 2=1) and (a[i] mod 2=0) then n:=n 1;

write(a[i],' ');

end;

writeln;

writeln('Искомых элементов: ',n);

end.

ПОКАЗАТЬ ОТВЕТЫ
Человек2029 Человек2029  13.05.2021 15:45

Var

i,n:integer;

a:array[1..20]of integer;

begin

writeln('Исходный массив:');

for i:=1 to 20 do

begin

a[i]:=random(10);

if (i mod 2=1) and (a[i] mod 2=0) then n:=n 1;

write(a[i],' ');

end;

writeln;

writeln('Искомых элементов: ',n);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика