Написать программу для паскаля. дана квадратная матрица порядка n(n=5). если в данной матрице a нет отрицательных элементов, то транспонировать её, иначе выдать сообщение.

tolstykh2005ow2t1s tolstykh2005ow2t1s    2   28.05.2019 05:40    0

Ответы
Graxx Graxx  25.06.2020 15:52
Uses crt;
const N=2;
var a:array [1..N,1..N] of real;
    i,j,k:integer;
begin
     k:=0; writeln('Введите матрицу:');
     for i:=1 to N do
         for j:=1 to N do
         begin
              read(a[i,j]);
              if a[i,j]<0 then inc(k);
         end;
     if k>0 then writeln('В матрице отрицательный элемент')
     else
         for i:=1 to N do
         begin
             for j:=1 to N do
             write(a[j,i]:3:0);
             writeln;
         end;
end.      
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика