Написать программу для паскаль найдите среднюю температуру для дней, когда температура поднималась выше 0 градусов, и определите количество таких дней. программа получает на входе количество дней, в течение которых проводилось наблюдение, затем для каждого дня вводится температура.

luchik1608 luchik1608    2   08.06.2019 03:10    0

Ответы
соня1571 соня1571  07.07.2020 13:53
var
  m, k, d1: single;
  i, t, d: byte;

begin
  readln(t);
  writeln();
  for i := 1 to t do
  begin
    readln(k);
    if (k > 0) then
    begin
      d1 += k;
      d  += 1;
    end;
  end;
  writeln(d1 / d);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика