Написать программу для abc паскаль. нужно сделать так, чтобы программа в ответе выдала xoxoxoxoxo, но при этом мы указываем сколько должно быть столбцов, сколько рядов. должна получиться шахматная доска. 10 класс program ksenia и т.д. 39 ! больше нет(

NikaGoddesin NikaGoddesin    2   13.08.2019 14:20    0

Ответы
юлия20043 юлия20043  04.10.2020 16:04
Var n,m,i,j:integer;
begin
write('n = ');
readln(n);
write('m = ');
readln(m);
for i:=1 to n div 2 do
 begin
 for j:=1 to m div 2 do write('xo');
 if m mod 2 = 1 then write('x');
 writeln;
 for j:=1 to m div 2 do write('ox');
 if m mod 2 = 1 then write('o');
 writeln;
 end;
if n mod 2 = 1 then
 begin
 for j:=1 to m div 2 do write('xo');
 if m mod 2 = 1 then write('x');
 writeln;
 end;
end.

Пример:
n = 3
m = 5
xoxox
oxoxo
xoxox
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика