Написать программу: Дан одномерный массив С[100], заполненный числами из диапазона от -26 до 15. Написать программу, которая будет находить сумму элементов массива, стоящих на нечетных местах ЗАВТРА КРАЙ СДАТЬ

aarmen020 aarmen020    3   29.11.2021 18:43    2

Ответы
человек661 человек661  29.11.2021 18:50

program Prog;

var c: array[1..100] of Integer;

summ, i: Integer;

begin

randomize;

// заполнение

for i := 1 to 100 do

 c[i]:=random(42)-26;

// вывод массива

write('Массив: ');

for i := 1 to 100 do

 write(c[i],' ');

// вычисление суммы элементов на нечетных местах

for i := 1 to 100 do

 if ((i mod 2) = 1) then

  summ+=c[i];

writeln;

// вывод этой суммы

write('Сумма элементов на нечетных местах: ');

write(summ);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика