Написать алгоритм для паскаля. составить программу, которая после введённого с клавиатуры числа от 1 до 99 обозначает денежную единицу дописывающую слово "копейка" в правильной форме.

nastuxxxxa13 nastuxxxxa13    2   23.06.2019 04:50    0

Ответы
алексей041 алексей041  19.07.2020 07:24
//Составить программу, которая после введённого с клавиатуры числа от 1 до 99 обозначает денежную единицу дописывающую слово "копейка" в правильной форме.

begin
var a := ReadInteger;
var c : string;
Assert(a >= 1);
Assert(a <= 99);
case a of
1, 21, 31, 41, 51, 61, 71, 81, 91: c := 'Копейка';
2..4, 22..24, 32..34, 42..44, 52..54, 62..64, 72..74, 82..84, 92..94: c := 'Копейки';
5..20, 25..30, 35..40, 45..50, 55..60, 65..70, 75..80, 85..90, 95..100: c := 'Копеек';
end;
Writeln(a, ' ', c);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика