tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Надо в одномерном массиве элементы
Надо в одномерном массиве элементы которого целые числа вставить новый элемент перед первым отрицательным элементом
Typists1
3 06.08.2019 07:10
0
Ответы
supersuperolga1
02.08.2020 08:59
//Dev-C++ (C)
#include <stdio.h>
#define n 5
int main(void)
{int Array[n],NewEle,point,boo;
point=-1;
boo=1;
for(int i=0;i<n-1;i++)
{scanf("%d",&Array[i]);
if((Array[i]<0)&&(boo)){
point=i;
boo=0;}
}
if(point==-1) printf("No negative elements");
else
{scanf("%d",&NewEle);
for(int i=n-2;i>=point;i--)
Array[i+1]=Array[i];
Array[point]=NewEle;
for(int i=0;i<n;i++)
printf("%d ",Array[i]);}
return 0;}
Пример ввода:
1
-2
3
4
5
Пример вывода:
1 5 -2 3 4
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
polina04081
06.06.2021 10:41
Соединил линиями название устройств и название выполняемого им действия...
Оля11111110
06.06.2021 10:53
Как выполните сложение в восьмеричной системе счисления методом триады...
pinelike
06.06.2021 10:56
Пользователь вводит целую часть, числитель и знаменатель для простой дроби. Перевести эту дробь в десятичную. (Например, дробь: 2 3 / 8 в десятичном виде : 2.375) c++...
marekatyan
06.06.2021 11:03
с этим но лучше мне скинуть код я 3 раз так делаю у меня выдаёт эту ошибку добрые люди это нужно за ранее...
aksiniaplotniko
13.03.2019 20:38
Для групповых операций с файлами используются маски имен файлов. маска представляет собой последовательность букв, цифр и прочих допустимых в именах файлов символов....
Cat4ik
25.11.2019 06:23
Таблицы истинницы, кто решит получит много . , нужно...
moiytrewq20005
25.11.2019 04:27
Написать на c++ для действительных значений a и b составить программу решения линейного уравнения ax=b....
Verenea
30.10.2021 01:11
А) найдите десятичные эквиваленты чисел по их прямым кодам, записанных в 8-разрядном формате сотзнаком. А) 00110110 Б) 10011011...
ГолубьДеревенский
30.10.2021 01:16
те , сор по инфе 7 кл 1 четверть...
валерия852
30.10.2021 01:17
1. Разделите все устройства по функциям. Устройства для ввода информации Утройства для вывода информации Устройства, принимающие и отправляющие информацию. 2. Напишите...
Популярные вопросы
В чем заключалось значение битвы за Москву...
3
Знайди периметр прямокутника зі сторонами 3см і 4см. Накресли відрізок...
1
Цитаты характеризующие следующих персонажей повести: Вощёва, Чиклина,...
2
Якщо площу поверхні лиж біатлоніста збільшити в 2 раза то а) тиск...
3
Меншикти жылдамдыктын табу формуласы...
2
що спільне і відмінне між дієсловом і дієприсливником та дієприслівником...
1
Сторона основи правильної трикутної піраміди дорівнює 3 см, апофема...
3
Расстояние между двумя городами автобус проехал за 3 часа. За первый...
1
Экономико-географическое положение, население, природа и экономика...
2
Здравствуйте составить тезисный план статьи Судьба поэта- Ашальчи...
2
#include <stdio.h>
#define n 5
int main(void)
{int Array[n],NewEle,point,boo;
point=-1;
boo=1;
for(int i=0;i<n-1;i++)
{scanf("%d",&Array[i]);
if((Array[i]<0)&&(boo)){
point=i;
boo=0;}
}
if(point==-1) printf("No negative elements");
else
{scanf("%d",&NewEle);
for(int i=n-2;i>=point;i--)
Array[i+1]=Array[i];
Array[point]=NewEle;
for(int i=0;i<n;i++)
printf("%d ",Array[i]);}
return 0;}
Пример ввода:
1
-2
3
4
5
Пример вывода:
1 5 -2 3 4