Надо составить программу в паскале. известны координаты трех точек a(x1,y1), b(x2,y2), c(x3,y3). найти расстояние ас+ав.

ВампирLove ВампирLove    3   10.06.2019 20:50    1

Ответы
Алалутала Алалутала  09.07.2020 01:54
Var
  x1, x2, x3, y1, y2, y3, L: real;

begin
  Write('Введите через пробел координаты точки А: ');
  Readln(x1, y1);
  Write('Введите через пробел координаты точки B: ');
  Readln(x2, y2);
  Write('Введите через пробел координаты точки C: ');
  Readln(x3, y3);
  L := sqrt(sqr(x2 - x1) + sqr(y2 - y1)) + sqrt(sqr(x3 - x1) + sqr(y3 - y1));
  Write('Сумма длин AB+AC равна ', L:0:3)
end.

Тестовое решение:
Введите через пробел координаты точки А: -3 2
Введите через пробел координаты точки B: 4.3 1.8
Введите через пробел координаты точки C: 0 7
Сумма длин AB+AC равна 13.134
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика