Надо составить программу на паскале, которая будет писать все положительные значения f(x) на интервале от a до b с шагом h. Функция F(x) = 2cos(x)-1


Надо составить программу на паскале, которая будет писать все положительные значения f(x) на интерва

Relentlez Relentlez    1   21.05.2021 19:40    1

Ответы
mo14yn mo14yn  20.06.2021 19:41

Program trig;

var a,b,H:real;

Function F(n:real):real;

begin

F:=2*cos(n)-1;  

end;

begin

write('Введите шаг: ');

readln(H);

write('Введите интервал: ');

readln(a,b);

writeln('x    F(x)');

writeln('');

while a<=b do begin

 if(F(a) > 0) then writeln(a:0:2,'  ',F(a):0:2);

 a:=a+H;

 end;

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика