Надо написать программу в паскале. : введите три трёхзначных числа. найти разность между наибольшим м наименьшим. заранее !

сашулька00001 сашулька00001    2   08.06.2019 05:20    4

Ответы
Lisonьka124 Lisonьka124  07.07.2020 14:37
Begin
  var a, b, c: single;
  readln(a, b, c);
  writeln(max(a, max(b, c)) - min(a, min(b, c)));
end.

Позязя, расширеннее...
begin
  var a, b, c, d, e: single;
  readln(a, b, c);
  if (a < b) then
    d := a
  else
    d := b;
  if (c < d) then
    d := c;
  if (a > b) then
    e := a
  else
    e := b;
  if (c > e) then
    e := c;
    writeln(e - d);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика