Надо написать программу на Pascal. Вася готовится к муниципальному этапу олимпиады по информатике, он хочет показать на нём хороший результат. Чтобы добиться этого, он разработал собственную систему тренировок — он каждый день решает задачи. Причём, он решает разное количество задач в будние и в выходные дни.
В будний день Вася решает
X
задач, в выходной день —
Y
задач.
Выходным Вася считает каждый
K
-й день, то есть дни с номерами
K
,
2
K
,
3
K
,
…
являются выходными.
Вася будет готовиться к олимпиаде ровно
N
дней и он хочет заранее знать, сколько всего задач он решит. Считается, что Вася решает задачи, начиная с дня с номером 1.
Требуется написать программу, которая по данным
N
,
K
,
X
,
Y
вычисляет количество решённых задач.
Входные данные
В первой строке вводится натуральное число
N
(
1
⩽
N
⩽
1000
) - количество дней, которое Вася будет решать задачи для подготовки к олимпиаде.
Во второй строке вводится натуральное число
K
(
1
⩽
K
⩽
1000
) - номер первого выходного дня.
В третьей строке вводится натуральное число
X
(
1
⩽
X
⩽
1000
) - количество задач, которое Вася решает в будний день.
В четвёртой строке вводится натуральное число
Y
(
1
⩽
Y
⩽
1000
) - количество задач, которое Вася решает в выходной день.
Пример
входные данные
3
2
10
15
выходные данные
35
program abc;
var n,k,x,y:integer;
begin
readln(n);
readln(k);
readln(x);
readln(y);
writeln((k)*x+(n-k)*y);
end.