Начертить блок-схему и составить программу, которая вычислит среднее арифметическое четных(или не четных, без разницы) чисел на интервале от a до b включительно.
Блок-схема - в прилагаемом файле. var a,b,s,k,i:integer; begin writeln('A, B:'); readln(a,b); s:=0; k:=0; for i:=a to b do begin s:=s+i; k:=k+1; end; writeln('Среднее арифм. четных = ',s/k); end.
var a,b,s,k,i:integer;
begin
writeln('A, B:');
readln(a,b);
s:=0; k:=0;
for i:=a to b do
begin
s:=s+i; k:=k+1;
end;
writeln('Среднее арифм. четных = ',s/k);
end.
Пример:
A, B:
5 15
Среднее арифм. четных = 10