На вход программе подается список целых чисел. Используя любой алгоритм сортировки (пузырьком или камнем) найдите 3 наибольших элемента списка. Выведите эти элементы в любом порядке

elenaklass1 elenaklass1    3   21.12.2021 19:00    0

Ответы
DIANA89320 DIANA89320  21.12.2021 19:10

ответ:  список целых чисел - вводится через запятую

a = input()

s = []

snow = ''

while len(a) > 0:

   if a[0] != ',':

       if len(a) != 1:

           snow = snow + a[0]

           a = a[1:]

       else:

           snow = snow + a[0]

           s.append(int(snow))

           a = a[1:]

   else:

       s.append(int(snow))

       snow = ''

       a = a[1:]

s.sort()

s = list(reversed(s))

print(s[0], s[1], s[2])

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика