tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
На вход программе подается
На вход программе подается количество битов.составьте программу ,которая переводит биты в байты ,килобайты,мегабайты,гигабайты.заранее ! )
Арти2004
1 06.10.2019 18:20
7
Ответы
ilacher12
27.08.2020 14:07
Program bity;
var a, b, c, d, e: real;
begin
write ('Введите количество бит: ');
read (a);
b:=a/8;
c:=b/1024;
d:=c/1024;
e:=d/1024;
writeln ('Это столько байт: ', b:8:4);
writeln ('Это столько килобайт: ', c:8:4);
writeln ('Это столько мегабайт: ', d:8:4);
write ('Это столько гигабайт: ', e:8:4);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
shkolnik1233
06.09.2019 23:20
Когда издавалась книга пушкина капитанская дочка...
berrrdi
06.09.2019 23:20
Если два числа равны , то вывести их сумму, а иначе модуль разности...
Ники67
06.09.2019 23:20
:информационный объем текстового сообщения равен 3 кбайт. количество символов в тексте равно 2048. какова мощность алфавита, с которого записано данное текстовое сообщение?...
katy244
19.04.2020 23:47
Задача. Даны две переменные (а, в 0). Поменять значения этих переменных местами. (f.e. а=3; в=5, после обмена значений, а=5; в=3). Требования: Решение задачи выполнить...
Noa18
19.04.2020 23:47
1)Найдите все значения натуральных чисел X,Y,Z из интервала от 1 до 10,удовлетворяющих равенству: x^2+y^2=z^2 Заранее...
Milania0011
19.04.2020 23:47
Решите в программе паскаль Напишите программу, в которой осуществляется ввод целых чисел (ввод осуществляется до тех пор, пока не будет введён ноль) и определение минимального...
snopchenkoilya
19.04.2020 23:47
Дан условный оператор if x 2 then y:= x+7 else y:=x-20...
lanamalinena
19.04.2020 23:47
Ребят в этом я не разбираюсь...
braagin
18.11.2020 18:08
По логической функции составить логическую схему ...
danilvlasov139
18.11.2020 18:08
Построить таблицы истинности для логического выражения кто может! ...
Популярные вопросы
Once my friend ... ill. He was hot and had a we called in a ... ....
1
У першому овочесховищу було 75 тон картоплі а в другому 21 тона. У...
2
Прочитайте текст, расположенный справа. Для ответа на вопрос выберите...
2
с задачей и уравнением Химия...
3
Воздушный шар начал подъем с земли ровно в 6:00за полчаса он достиг...
3
нужно решение и ответзаранее ......
1
Put the verbs brackets into the correct form...
2
Постройте сечение многогранника Можно полностью с объяснением...
3
Развитие сюжета Кирик и алёнка...
3
F(x)=−8x^2+3x+14. Вычисли f(2)=...
2
var a, b, c, d, e: real;
begin
write ('Введите количество бит: ');
read (a);
b:=a/8;
c:=b/1024;
d:=c/1024;
e:=d/1024;
writeln ('Это столько байт: ', b:8:4);
writeln ('Это столько килобайт: ', c:8:4);
writeln ('Это столько мегабайт: ', d:8:4);
write ('Это столько гигабайт: ', e:8:4);
end.