На с++ напишите программу, которая сортирует элементы массива по возрастанию последней цифры десятичной записи чисел. входные данные первая строка содержит размер массива n . во второй строке через пробел n чисел – элементы массива. гарантируется, что 0 < n ≤ 10000 . выходные данные программа должна вывести в одной строке элементы массива, отсортированного в порядке возрастания последней цифры в десятичной записи чисел, разделив их пробелами. числа, у которых последняя цифра одинаковая, должны быть выведены в том же порядке, в котором они стояли в исходной последовательности. примеры входные данные 6 219 234 890 81 73 96 выходные данные 890 81 73 234 96 219

КэтринПирс23 КэтринПирс23    2   21.09.2019 06:10    44

Ответы
tntemirlan tntemirlan  08.10.2020 06:28
//g++  5.4.0

#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;

int main()
{
    size_t N;
    cin >> N;
    vector<int> a(N);
   
    for (size_t i = 0; i < N; ++i) 
        cin >> a[i];

    sort(a.begin(), a.end(), [&] (const int &z, cinst int&x) { 
        return z % 10 < x % 10; });
   
    for (const auto &i : a)
        cout << i << " ";
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика