На паскале. в текстовый файл t1 записана последовательность целых чисел, разделенных пробелами. написать программу, записывающую в текстовый файл t2 все положительные числа из t1.

yulyasmernyagi yulyasmernyagi    1   26.07.2019 04:11    1

Ответы
Ромчик0412 Ромчик0412  03.10.2020 13:17
// PascalABC.NET 3.1, сборка 1218 от 12.04.2016
begin
  var a:=ReadAllLines('int.txt').JoinIntoString.ToIntegers;
  Print('Прочитано'); a.Println;
  var b:=a.Where(x->x>0);
  Print('Отобрано'); b.Println;
  var f:=OpenWrite('out.txt');
  foreach var e in b do Write(f,e,' ');
  f.Close
end.

Тестовое решение:
Прочитано -5 8 -3 -2 0 -6 4 9 0 0 4 -4 -1 0 -1 3 6 7 1 8 0 2 -5 -2 9
Отобрано 8 4 9 4 3 6 7 1 8 2 9
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика