) На известном вам языке программирования напишите программу:
Даны три целых числа. Определить количество положительных чисел.

Код программы:

Artem19092002 Artem19092002    1   17.05.2020 22:09    1

Ответы
UILA336 UILA336  14.10.2020 21:34

На Pascal:

var a,b,c,count:integer;

begin

readln(a);

readln(b);

readln(c);

count := 0;

if a > 0 then begin

  count := count + 1

end;

if b > 0 then begin

  count := count + 1

 end;

if c > 0 then begin

  count := count + 1

 end;

writeln(count);

end.

На Python:

a = int(input())

b = int(input())

c = int(input())

count = 0

if a > 0:

   count = count + 1

if b > 0:

   count = count + 1

if c > 0:

   count = count + 1

print(count)

Еще Python:

p = 0

for i in range(1,4):

   n = int(input())

   if n > 0:

       p += 1

print(f'Количество положительных чисел {p}')

ПОКАЗАТЬ ОТВЕТЫ
vitusyaischuk vitusyaischuk  14.10.2020 21:34
ответ:

PascalABC.NET:

begin    Println('Количество:', ReadArrInteger(3).Count(x -> x > 0));end.Объяснение:

Println(a,b) - выводит на экран a и b, разделяя их пробелом.

ReadArrInteger(3) - возвращает массив из 3 введённых чисел.

.Count(x -> x > 0) - считает количество элементов массива, удовлетворяющим условию x > 0, где x - элемент.


) На известном вам языке программирования напишите программу: Даны три целых числа. Определить колич
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика