На циклы. составить программу в ! ! 3. однажды умный бедняк попросил у скупого богача приюта на две недели, причем сказал: «за это я заплачу тебе в первый день 1 рубль, во второй - 2, в третий -3 и т.д., но ты будешь мне подавать милостыню: в первый день 1 копейку, во второй -2, в третий-4 и т.д. увеличивая милостыню каждый день вдвое». богач с радостью согласился. сколько барыша принесла эта сделка богачу?

Санёк1616 Санёк1616    2   20.05.2019 22:20    5

Ответы
Tumkanator Tumkanator  14.06.2020 13:18

program zadanie;
var
i, n: integer;
bednyak, bogaty: real;
begin
bednyak:=0;
bogaty:=1;
n:=1;
for i:=1 to 14 do
begin
bednyak:=bednyak+1;
bogaty:=bogaty+n;
n:=n*2;
end;
bogaty:=bogaty/100;
writeln('Заплатил бедняк богачу (рублей): ', bednyak);
writeln('Заплатил богач бедняку (рублей): ', bogaty);
writeln('ответ: Богач заплатил бедняку на ', bogaty, ' рублей больше');
end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика