tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Мне нужно ответь составить
Мне нужно ответь составить программу, которая бы запрашивала хнач , хкон , шаг c и определяла сумму всех отрицательных чисел от хнач до хкон с шагом с (решить , используя цикл с постусло-вием – repeat … until).
vikapuhtina
3 31.07.2019 17:10
4
Ответы
anastasiykucher
03.10.2020 18:47
//Pascal ABC.NET 3.1 сборка 1256
Var
n,k,c,s,kar:real;
i:integer;
begin
read(n,k,c);
i:=0;
s:=0;
kar:=n;
repeat
if n<0 then s:=s+n;
inc(i);
n:=kar+i*c;
until n>k;
writeln(s);
end.
Пример ввода:
-3
1
1.1
Пример вывода:
-5.7
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
thero10
28.11.2019 18:15
Напишите программу для решения следующей . камера наблюдения регистрирует в автоматическом режиме скорость проезжающих мимо неё автомобилей, округляя значения скорости до целых...
Лллиззза
28.11.2019 18:15
нужно написать программу на языке с++ !...
ulyanahoroshina
08.12.2020 05:04
Статья, набранная на компьютере в варианте представления KOI8 содержит 256 страниц, на каждой странице 30 строк, в каждой строке 32 символа. Определите информационный объём статьи...
denisnickolenko
08.12.2020 05:04
Свойства логических операций 1.а*b*c+¯a*b*c 2. a*b+a*b*c+a*b*d ответ a•b решить задание по информатике 8 класс;...
lavelas2008
05.12.2020 12:26
скорее! 1 Составить таблицу истинности для следующего логического выражения. F = А&̅ (A&B) ∨ (A → B) 2 Найти значение логического выражения. F = (0 &1) v (0 & 1)...
Pentianоs
05.12.2020 12:28
Обчислити значення функцій рядкової величини С=«обчислення» мовою математики та мовою Python. 1)С1 [7:10] 2) С2 [:8] 3) С...
tubip888
21.07.2019 15:10
Расскажи о двоичного кодирования информации с целью её хранения и передачи...
A1n2g3e4l5i6n7a87
21.07.2019 15:10
На 4 1.напишите программу, которая пользователя. использовать две переменные фамилию и имя. 2.напишите программу, которая найти сумму 5 чисел. 3.напишите программу, которая найти...
Adonis12321
21.07.2019 15:10
Напишите лишнее число : 00100011011110021001 обьясните почему вы выбрали такой ответ...
tryx3
18.02.2020 23:54
Напишите программу для подсчета четных и нечетных чисел среди любых 20 введенных с клавиатуры целых чисел, используя булевскую функцию Odd, возвращающую True в случае нечетного...
Популярные вопросы
Апределите аснову предложений язык прочно вашёл в круг тех языков...
1
Три предложения на тему моё любимое животное...
1
Школьня футбольная команда выиграла в 3 раза больше матчей, чем проиграла. четыре...
3
Наишите: 4 пословицы 4 крылатых выражения 4 фразеологизмы...
3
Продолжите фразу. 1) действия объекта...
2
Из 30 учащихся класса 20% учатся на отлично . сколько учащихся не отличники?...
2
Уметь читать и любить читать - это одно и тоже понятие ....
3
Весело горит яркий огонек костра начинаетприпекать...
2
Сократите дроби 32/72 , 20\36, 18\90...
1
Сочинить четверостийший стих со словами частное-опастное и свойство-устройство...
2
Var
n,k,c,s,kar:real;
i:integer;
begin
read(n,k,c);
i:=0;
s:=0;
kar:=n;
repeat
if n<0 then s:=s+n;
inc(i);
n:=kar+i*c;
until n>k;
writeln(s);
end.
Пример ввода:
-3
1
1.1
Пример вывода:
-5.7