Массив содержит значения отметок 12 учащихся класса за сам. работу. На дополнительном занятии учащиеся переписали работу и получили отметки на выше (кроме тех, кто получил 10). Составить программу, которая выводит отметки, полученные учениками первоначально и после работы над ошибками

aleksminaev aleksminaev    1   01.12.2021 19:26    0

Ответы
Дашуля110506 Дашуля110506  12.01.2022 19:59

var

 i: integer;

 a: array [1..12] of integer;

begin

 for i := 1 to 12 do

   readln(a[i]);    

 writeln ('До работы над ошибками', a);

 for i := 1 to 12 do

 begin

   if a[i] <> 10 then

   a[i]:= a[i] + 1;

 end;

 writeln ('После работы над ошибками', a)

end.

Язык pascal abc

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика