Массив констант содержит информацию о месяцах рождения 10 учащихся класса . Составьте программу , вычисляющую ( попросили найти не только сколько зимой , но и сколько летом родилось, кого больше родилось летом или зимой Pascal abc


Массив констант содержит информацию о месяцах рождения 10 учащихся класса . Составьте программу , вы

tolodono tolodono    1   18.10.2021 08:40    47

Ответы
bobina2 bobina2  18.10.2021 08:50

const

a : array[1..10] of integer = (12, 5, 4, 1, 9, 7, 8, 2, 3, 2);

var k, _counterW, _counterS: integer;

begin

_counterS := 0;

_counterW := 0;

for k := 1 to 10 do

   begin

   if (a[k] = 12) or (a[k] = 1) or (a[k] = 2) then

       _counterW := _counterW + 1

   else if (a[k] = 6) or (a[k] = 7) or (a[k] = 8) then

       _counterS := _counterS + 1;

   end;

writeln('Количество родившихся летом:', _counterS);

writeln('Количество родившихся зимой:',_counterW);

if _counterW > _counterS then

   writeln('Зимой родилось большее количество учащихся!')

else if _counterS > _counterW then

   writeln('Летом родилось большее количество учащихся!')

else

   writeln('Летом и зимой родилось одинаковое число учащихся!');

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика