tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Массив а состоящий из n
Массив а состоящий из n элементов. найти среднее арифметическое его элементов с нечетными номерами.
Владушкаcat
2 20.08.2019 05:40
0
Ответы
Выгуки
05.10.2020 06:40
// PascalABC.NET 3.2, сборка 1379 от 21.01.2017
// Внимание! Если программа не работает, обновите версию!
// Элементы нумеруются от нуля
begin
var a:=ArrRandom(ReadInteger('n='),-99,99); a.Println;
Writeln('Mнечет=',a.Where((x,i)->i.IsOdd.Average)
end.
Пример
n= 16
-72 40 47 -74 -34 -99 8 -83 55 49 -6 -26 -15 2 4 0
Mнечет=-23.875
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Эммикэт
21.07.2019 01:20
1. операция над фрагментом с целью его последующего повторения (11 букв) 2. операция открытия документа (8 букв) 3. минимальная единица текста (6 букв) 4. некоторое...
S1mplendnnd
21.07.2019 01:20
Автомат получает на вход трёхзначное число. по этому числу строится новое число по следующим правилам. 1. перемножаются первая и вторая, а также вторая и третья цифры....
Віка579
21.07.2019 01:20
При регистрации в компьютерной системе каждому пользователю выдаётся пароль, состоящий из 15 символов и содержащий только символы из 12-символьного набора: а, в, c,...
alekcandrina200
21.07.2019 01:20
Вмассиве из 15 целых чисел найти сумму минимального и максимального элементов...
JumpyWizzard
21.07.2019 01:20
Для перевода температуры, измеренной по шкале цельсия, в соответствующую температуру по шкале фаренгейта необходимо температуру по цельсию умножить на 9/5 и прибавить...
Инна0606
21.07.2019 01:20
Решение на построение линейных алгоритмов на языке программирования паскаль (8 класс) решить 2 , . 1)напишите программу в которой на вход подается целое число, время...
mailrujl
21.07.2019 01:20
Сколько единиц в двоичной записи шестнадцатеричного числа вес216?...
LiNa20142014
21.07.2019 01:20
Гарри поттер поменял волшеб- ную палочку на волшебный план- шет, в котором установлена вол- шебная программа обработки электронных таблиц, а волшебного графического...
ammaa09
21.07.2019 01:20
50 : описать стандартные элементы окна браузера! заранне !...
lspkorvo
21.07.2019 01:20
Написать программу тест состоящую из пяти произвольных вопросов результат...
Популярные вопросы
Длина-90,ширина-45, высота-30...
3
Задание 2. Чему учил Конфуций? Конфуций советовал правителям«Относиться...
2
Якої пори року відбувалися події у творі В. Винниченка «Момент»:...
3
При каких значениях х разность дробей :5х/х+1 и 1/1-х^2 равна дроби...
1
До ть! М яса на них розкладали це який художній засіб....
2
Нийти сторону-FK -треугольника-FKH, если AB=5см н о...
3
Определить скорость спутника на орбите высотой равной диаметру Земли...
1
Моральные заповеди которые руководствует человек5-7 шт приводите...
2
Какая сила тяжести действует на гирю массой 500 г, находящуюся:...
2
Население города N 2 млн человек, из них старики и дети составляет...
3
// Внимание! Если программа не работает, обновите версию!
// Элементы нумеруются от нуля
begin
var a:=ArrRandom(ReadInteger('n='),-99,99); a.Println;
Writeln('Mнечет=',a.Where((x,i)->i.IsOdd.Average)
end.
Пример
n= 16
-72 40 47 -74 -34 -99 8 -83 55 49 -6 -26 -15 2 4 0
Mнечет=-23.875