Линейные алгоритмы. на с++ 1. составить программу вычисления значения функции y=7*x^2+3*x-6 при любом значении x. 2. заданы координаты трех вершин треугольника (х1, y1), (х2, у2), (х3, у3). найти его периметр и площадь. 3. дано а. не используя никаких функций и никаких операций, кроме умножения, получить а^8 за три операции; а^10 и а^16 за четыре операции. 4. дано вещественное число а. пользуясь только операцией умножения, получить: а^21 за шесть операций. 5. известно значение температуры по шкале цельсия. найти соответствующее значение температуры по шкале кельвина (для пересчета по шкале кельвина: абсолютное значение нуля соответствует 273,15 градуса по шкале цельсия).

customsto customsto    3   17.09.2019 04:40    38

Ответы
msakinat msakinat  07.10.2020 21:06
Я оформил каждое задание в отдельной функции перед сдачей проверь на правильность выполнения т.к. у меня нет среды разработки и компилятора)) Перепрофилировался в джаву с питоном))
ПОКАЗАТЬ ОТВЕТЫ
ekaterintys ekaterintys  23.01.2024 13:01
Учитель: Здравствуйте! Сегодня мы будем решать задачи на линейные алгоритмы на языке программирования С++.

Задача 1. Мы должны написать программу, которая вычисляет значение функции y = 7*x^2 + 3*x - 6 для любого заданного значения x. Для этого воспользуемся языком программирования C++. Вот как будет выглядеть наша программа:

```
#include
using namespace std;

int main() {
// Вводим значение переменной x
float x;
cout << "Введите значение x: ";
cin >> x;

// Вычисляем значение функции y
float y = 7*x*x + 3*x - 6;

// Выводим результат на экран
cout << "Значение функции y = " << y << endl;

return 0;
}
```

Обоснование: В этой программе мы используем ввод и вывод данных с помощью потоков ввода и вывода С++ (`cin` и `cout`). Мы объявляем переменную `x`, в которую пользователь будет вводить значение `x`. Затем мы производим вычисления, используя формулу функции y = 7*x^2 + 3*x - 6. Результат вычисления записываем в переменную `y` и выводим на экран.

Пояснение: Эта программа позволяет нам вычислить значение функции для любого заданного `x`. Например, если мы введем `x = 2`, программа выведет на экран значение `y = 25`.

Шаги решения:
1. Вводим значение переменной `x` с помощью `cin`.
2. Вычисляем значение функции, используя формулу `y = 7*x*x + 3*x - 6`.
3. Записываем результат вычислений в переменную `y`.
4. Выводим значение `y` на экран с помощью `cout` и оператора `<<`.

Задача 2. Теперь решим задачу на нахождение периметра и площади треугольника по заданным координатам его вершин.

```cpp
#include
#include
using namespace std;

int main() {
// Вводим координаты вершин треугольника
float x1, y1, x2, y2, x3, y3;
cout << "Введите координаты вершин треугольника (x1, y1), (x2, y2), (x3, y3): ";
cin >> x1 >> y1 >> x2 >> y2 >> x3 >> y3;

// Вычисляем длины сторон треугольника
float side1 = sqrt(pow(x2 - x1, 2) + pow(y2 - y1, 2));
float side2 = sqrt(pow(x3 - x2, 2) + pow(y3 - y2, 2));
float side3 = sqrt(pow(x3 - x1, 2) + pow(y3 - y1, 2));

// Вычисляем периметр треугольника
float perimeter = side1 + side2 + side3;

// Вычисляем полупериметр треугольника
float semiperimeter = perimeter / 2;

// Вычисляем площадь треугольника по формуле Герона
float area = sqrt(semiperimeter * (semiperimeter - side1) * (semiperimeter - side2) * (semiperimeter - side3));

// Выводим результаты на экран
cout << "Периметр треугольника: " << perimeter << endl;
cout << "Площадь треугольника: " << area << endl;

return 0;
}
```

Обоснование: В этой программе мы снова используем потоки `cin` и `cout` для ввода и вывода данных. Мы вводим координаты трех вершин треугольника `x1, y1, x2, y2, x3, y3`. Затем мы вычисляем длины сторон треугольника с помощью формулы дистанции между двумя точками в прямоугольной системе координат (`sqrt(pow(x2 - x1, 2) + pow(y2 - y1, 2))`). Периметр треугольника вычисляется как сумма длин его сторон, а площадь - по формуле Герона.

Шаги решения:
1. Вводим координаты вершин треугольника с помощью `cin`.
2. Вычисляем длины сторон треугольника, используя формулу дистанции между двумя точками.
3. Вычисляем периметр треугольника, складывая длины его сторон.
4. Вычисляем полупериметр треугольника, деля периметр на 2.
5. Вычисляем площадь треугольника по формуле Герона.
6. Выводим периметр и площадь треугольника на экран с помощью `cout` и оператора `<<`.

Задача 3. Теперь решим задачу на возведение числа `a` в степень.

```cpp
#include
using namespace std;

int main() {
// Вводим значение переменной a
float a;
cout << "Введите значение a: ";
cin >> a;

// Вычисляем a в степени 8, 10 и 16
float a8 = a * a * a * a * a * a * a * a;
float a10 = a8 * a * a;
float a16 = a8 * a8;

// Выводим результаты на экран
cout << "a^8 = " << a8 << endl;
cout << "a^10 = " << a10 << endl;
cout << "a^16 = " << a16 << endl;

return 0;
}
```

Обоснование: В этой программе мы снова используем потоки `cin` и `cout`, чтобы пользователь мог ввести значение переменной `a`. Затем мы вычисляем a в степени 8, 10 и 16, используя только операцию умножения.

Шаги решения:
1. Вводим значение переменной `a` с помощью `cin`.
2. Вычисляем a в 8-й степени, умножая `a` на себя 8 раз.
3. Вычисляем a в 10-й степени, умножая `a` в 8-й степени на `a` во 2-й степени.
4. Вычисляем a в 16-й степени, умножая `a` в 8-й степени на `a` в 8-й степени.
5. Выводим результаты на экран с помощью `cout` и оператора `<<`.

Задача 4. Решим задачу на возведение числа `a` в 21-ю степень.

```cpp
#include
using namespace std;

int main() {
// Вводим значение переменной a
float a;
cout << "Введите значение a: ";
cin >> a;

// Вычисляем a в 21-й степени
float a2 = a * a;
float a4 = a2 * a2;
float a5 = a4 * a;
float a10 = a5 * a5;
float a20 = a10 * a10;
float a21 = a20 * a;

// Выводим результаты на экран
cout << "a^21 = " << a21 << endl;

return 0;
}
```

Обоснование: В этой программе мы снова используем потоки `cin` и `cout` для ввода и вывода данных. Мы вводим значение переменной `a`. Затем мы используем только операцию умножения для вычисления `a` в 21-й степени.

Шаги решения:
1. Вводим значение переменной `a` с помощью `cin`.
2. Вычисляем `a` во 2-й степени, умножая `a` на `a`.
3. Вычисляем `a` в 4-й степени, умножая `a` во 2-й степени на `a` во 2-й степени.
4. Вычисляем `a` в 5-й степени, умножая `a` в 4-й степени на `a`.
5. Вычисляем `a` в 10-й степени, умножая `a` в 5-й степени на `a` в 5-й степени.
6. Вычисляем `a` в 20-й степени, умножая `a` в 10-й степени на `a` в 10-й степени.
7. Вычисляем `a` в 21-й степени, умножая `a` в 20-й степени на `a`.
8. Выводим результаты на экран с помощью `cout` и оператора `<<`.

Задача 5. Теперь решим задачу на пересчет температуры по шкале Цельсия в температуру по шкале Кельвина.

```cpp
#include
using namespace std;

int main() {
// Вводим значение температуры по шкале Цельсия
float celsius;
cout << "Введите значение температуры по шкале Цельсия: ";
cin >> celsius;

// Пересчитываем температуру в температуру по шкале Кельвина
float kelvin = celsius + 273.15;

// Выводим результат на экран
cout << "Температура по шкале Кельвина: " << kelvin << endl;

return 0;
}
```

Обоснование: В этой программе мы также используем потоки `cin` и `cout` для ввода и вывода данных. Мы вводим значение температуры по шкале Цельсия. Затем мы пересчитываем температуру в температуру по шкале Кельвина, используя формулу `kelvin = celsius + 273.15`.

Шаги решения:
1. Вводим значение переменной `celsius` с помощью `cin`.
2. Пересчитываем температуру в температуру по шкале Кельвина, прибавляя к значению `celsius` 273.15.
3. Выводим результат на экран с помощью `cout` и оператора `<<`.

Это подробное решение задачи на линейные алгоритмы на языке программирования C++. Если у вас возникнут вопросы, не стесняйтесь задавать их!
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика