Как вывести функцию сравнения двух чисел в паскале с mod и div не используя if? напишите программу, которая считывает два целых положительных числа aa и bb и выводит наибольшее значение из них.

dashagorbunova5 dashagorbunova5    3   10.09.2019 09:20    0

Ответы
eugenybusuek eugenybusuek  07.10.2020 05:01
var a,b,a1,b1:word;
 begin
writeln('Введите два натуральных числа');
readln(a,b);
a1:=a div b;
 a1:=((a1+2) div (a1+1)) mod 2;
 b1:=(a1+1) mod 2;
writeln('Число ', a*a1+b*b1,' не меньше ',a*b1+b*a1);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика