Исправьте ошибку , я выполнял задание
Напишите программу, которая для произвольного натурального двузначного числа определяет сумму и произведение его цифр
var x, a, b, c, d: integer;
begin
writeln ('число');
readln (x);
a:=x mod 10 ;
b:=x mod 10;
c:=a*b;
d:=a+b;
writeln ('произведениеc=', c);
writeln ('сумма=', d);
end.