Информатика! ПИТОН Строки

Я очень туплю

Значение выражения

Дана строка, состоящая из n цифр (т.е. однозначных чисел), между которыми стоит n−1 знак операции, каждый из которых может быть либо +, либо −. Вычислите значение данного выражения.

Входные данные

На вход подается строка, состоящая из цифр, а также символов + и −.

Выходные данные

Выведите ответ на задачу.

Примеры

Ввод

1+2-3

Вывод

0

AlexxP AlexxP    1   23.03.2020 17:02    99

Ответы
fsks fsks  12.10.2020 03:04

https://onlinegdb.com/S1IjQ7SUU --- Код на Python в песочнице

Если нужен сам код сразу - она ниже (про отступы не забудь, если будешь копировать прямо отсюда):

row = str(input("Enter your math expression: "))

a = []

res = 0

for i in range(len(row)):

   a.append(row[i:i+1])

#    print(a[i])  --  Если хочешь посмотреть на результаты

#                     посимвольного разделения строки

#                     (больше для себя комментарий делал)

for i in range(len(row)):

   if (a[i] == "-"):

       res = res - (int(a[i+1]))

   elif (a[i] == "+"):

       res = res + (int(a[i+1]))

   elif (i == 0):

       res = res + (int(a[i]))

print("Resul of your math expression: ",res)

Если что, результати с консоли вывода тоже прикрепил

Удачи там с Python-ом ))


Информатика! ПИТОН СтрокиЯ очень туплюЗначение выраженияДана строка, состоящая из n цифр (т.е. одноз
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика