Инфа напишите код на python, плз Летом, в Ялте, ученики стоят в очереди за мороженным. Известно, что в очереди стоит N учеников. Каждый в очереди планирует купить себе одно мороженное. Как правило, но не всегда, два мороженных в одни руки продавец продаёт быстрее, чем одно. Поэтому некоторые из учеников решили объединиться в пары. Объединиться в пару могут только рядом стоящие ученики, чтобы не была нарушена очередность продажи мороженного, при этом мороженное на объединившихся в пары учеников всегда покупает тот, кто стоял первым из них.
Известно, что на продажу i-му ученику из очереди одного мороженного продавец потратит Xi секунд, на продажу двух мороженных — Yi секунд. Напишите программу, которая подсчитает минимальное время, за которое могут быть обслужены все покупатели.
Со стандартного потока ввода сначала считывается число N (1 ≤ N ≤ 10000) — количество покупателей. Далее в N строках вводятся пары целых неотрицательных чисел Xi, Yi. (1 ≤ Xi, Yi ≤ 100) -время обслуживания для каждого покупателя. Где первая пара чисел – это время обслуживания первого ученика в очереди, вторая пара – время обслуживания второго ученика в очереди и т.д.
Требуется вывести минимальное время в секундах, за которое могут быть обслужены все покупатели.

kaltaeva98 kaltaeva98    3   02.04.2021 21:47    17

Ответы
Gulya6922 Gulya6922  02.05.2021 21:50

Не очень уверен в правильности данного решения, потестил немного на разных вариантах - вроде работает. Но ощущение, что какой-то он корявый...

n = int(input('Введите количество учеников: '))

a = [list(map(int, input(f'Введите 1<=Xi и Yi<=100 через пробел для {i+1}-го ученика: ').split())) for i in range(n)]

print(a)

i = 0

summ = 0

while i <= len(a)-1:

   if i < len(a)-2:

       if a[i][1] < a[i+1][1]:

           summ += a[i][1]

           i += 2

       else:

           summ += a[i][0]

           i += 1

   elif i == len(a)-2:

       summ += a[i][1]

       i += 2

   else:

       summ += a[i][0]

       i += 1

print(summ)

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика