Хелп,умоляю..написать программу для подсчёта количества чётных и нечётных цифр любого числа( в паскале), .​

samal22 samal22    2   07.10.2019 22:20    3

Ответы
arinamal1 arinamal1  10.10.2020 02:39

var

   a, chet, nechet : integer;

   

begin

   write('введите число: ');

   readln(a);

   while a > 0 do begin

       if (a mod 10) mod 2 = 0then chet += 1 else nechet += 1;

       a := a div 10;

   end;

   writeln('четных: ', chet);

   writeln('не четных: ', nechet);

end.

программа считает 0 как четное число. Если нужно что бы 0 не учитывался при подсчете то необходимо строку:

if (a mod 10) mod 2 = 0then chet += 1 else nechet += 1;

заменить на:

if a mod 10 <> 0 then if (a mod 10) mod 2 = 0then chet += 1 else nechet += 1;

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика