Hапишите программу на языка программирования паскаль АВС. Напишите программу в которой осуществляется ввод целых чисел(ввод осуществляется до тех пор, пока не будет введен ноль) и подсчет суммы и среднего арифметического введенных положительных чисел. Используйте оператор repeat
program rabota;
var a,i,b,e:real;
begin
i:=0;
repeat
readln(a);
e:=e+a;
i:=i+1;
until a=0;
i:=i-1;
b:=e/i;
writeln('Сумма равна',e);
writeln('Среднее арифметическое равно',b);
end.
В крации: даны значения a=вводимого числа e=суммы чисел и b=среднее арифметическое
i=сколько чисел ты ввёл
Там будет i:=i-1 тк по задаче нужно ввести 0, но оно тоже считается и поэтому прибавляется i+1.