Добрый вечер. , написать программу (на pascal) для решения квадратного уравнения.

wrrrr wrrrr    3   21.06.2019 11:20    0

Ответы
polyakkate polyakkate  17.07.2020 00:00
Var a,b,c,d,x1,x2:real;
begin
read(a,b,c);
d:=sqr(b)-4*a*c;
if(d>0)then begin
x1:=(-b+sqrt(d))/(2*a);
x2:=(-b-sqrt(d))/(2*a);
writeln('x1=',x1:3:5,' x2=',x2:3:5);
end else if(d=0)then begin x1:=-b/(2*a); writeln(x1:5);end
else writeln('Нет корней. Дискриминант меньше 0');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика