Добрый день. , , написать программу для вычисления суммы элементов арифметической и прогрессии.

marina27081981 marina27081981    2   04.07.2019 11:30    0

Ответы
timkaserka timkaserka  02.10.2020 19:57
{программу для вычисления суммы элементов арифметической прогрессии}
var i,j,q,d,n,s,s0,sm:integer;
begin
write('Введите число эле-в, первый элемент и шаг  ариф. прогрессиии шаг');
read(n,s0,d);
for i:= 1 to n do begin
s:= s0 +(i-1)*d; write(s:2);
sm:= sm + s;end;
write(sm:4);end.

{программу для вычисления суммы элементов геометрической прогрессии}
var i,j,q,n:integer; z,b,b0,sm:real;
begin
write('Введите число эле-в, первый элемент и знаменатель  геом. прогрессиии');
read(n,b0,q);
for i:= 1 to n do begin
z:=i;
b:= b0 *Power(q,z-1);
write(b:4);
sm:= sm + b;end;write(sm:4);end.
ПОКАЗАТЬ ОТВЕТЫ
Darya0012 Darya0012  02.10.2020 19:57
Var a1,b1,n,d:integer;
sa:real;
begin
writeln('vvedite perviy element arefmeticescoy progressii=');
readln (a1);
writeln('skoliko cisel');
readln(n);
writeln('raznosti arefmeticescoy progressii=');
readln(d);
writeln ( 'summa arefmeticescoy progressii=');
sa:=((2*a1+(n-1)*d)/2)*n;
write(sa);
readln;
end.


var i,j,q,n:integer; 
z,b,b1,sg:real;
begin
write('vvedite perviy element geometricescoy progressii');
read(b1);
writeln('q=');
readln(q);
writeln('n=');
readln(n);
for i:= 1 to n do
 begin
z:=i;
b:= b1 *Power(q,z-1);
sg:= sg + b;
end;
writeln('summa geometricescoy progressii=',sg);
readln;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика