Для паскаля є цілочисельний масив n*m елементів. знайти номер рядка з мінімальною сумою модулів елементів. (есть целочисленный массив n * m элементов. найти номер строки с минимальной суммой модулей элементов.) написать программу и объяснить что к чему

Liza1556 Liza1556    2   25.09.2019 05:00    0

Ответы
kzifi kzifi  08.10.2020 17:28
PascalABC.NET 3.3.5, сборка 1662 от 29.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var (n,m):=ReadInteger2('Количество строк и столбцов в массиве:');
  Writeln('*** Исходный массив ***');
  var a:=MatrRandom(n,m,-99,99);
  a.Println(4); Writeln(4*a.ColCount*'-');
  Writeln(a.Rows.Select(r->r.Select(t->Abs(t)).Sum).ToArray.IndexMin+1)
end.

Для паскаля є цілочисельний масив n*m елементів. знайти номер рядка з мінімальною сумою модулів елем
ПОКАЗАТЬ ОТВЕТЫ
vbvb2006 vbvb2006  08.10.2020 17:28
//более простым языком
const
  maxn = 100;

type
  myarr = array [1..maxn, 1..maxn] of longint;

var
  a: myarr;
  n, m, i, j, sum, ini, max: longint;

begin
  readln(n, m);
  max := 0;
  for i := 1 to n do begin
    sum := 0;
    for j := 1 to m do begin
      read(a[i, j]);
      sum := sum + abs(a[i, j]);
    end;
    if (sum > max) then begin
      ini := i;
      max := sum;
    end;
  end;
  writeln(ini);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика