Даны три натуральных числа. напишите программу в паскале , определяющую , существует ли треугольник с такими длинами сторон. если такой существует , то определите его тип (равносторонний , равнобедренный, разносторонний) ! заранее .

Arx Arx    1   03.06.2019 02:50    4

Ответы
0Alis11 0Alis11  03.07.2020 15:59
Var
a,b,c,k:integer;
begin
readln(a,b,c);
if (a+b>c)and(b+c>a)and(a+c>b) then begin
writeln('треугольник существует');
k:=1
end
else writeln('треугольник не существует');
if (a=b)and(a=c) and (k=1) then
writeln('равносторонний');
if (((a=b)and(a<>c))or((c=b)and(c<>a))or((c=a)and(c<>b)))and (k=1) then
writeln('равнобедренный');
if (a<>b)and(c<>b)and(a<>c)and (k=1) then
writeln('разносторонний')
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика