Даны натуральные числа k и n. составить программу формирования массива а, элементами которого являются числа, сумма цифр которых равна k и которые не больше n.
составить программу на паскале.

Вундеркингsd Вундеркингsd    2   18.10.2019 17:18    43

Ответы
2007пуля 2007пуля  05.08.2020 08:29

uses crt;

type arr=array[1..1000]of integer;

 

var N, K, C: integer;

a : arr;

 

function sum(n:integer):integer;

var s:integer;

begin

s:=0;

while n<>0 do

begin

 s:=s+n mod 10;

 n:=n div 10;

end;

sum:=s;

end;

 

procedure fill(var a:arr, C, N, K: integer);

var i:integer;

begin

c:=0;

for i:=1 to N do if sum(i)=k then

begin

 inc(c);

 a[c]:=i;

end;

end;

 

begin

clrscr;

write('N K-> ');

readln(N, K);

fill(a, c, N, K);

for i:=1 to с do write(a[i],' ');

readln;

end.

Объяснение:

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика