Дано натуральнок k от 1 до 180.написать программу для определения цифры, которая находится в k-той позиции последовательности . формат входных данных файл содержит число k-позиция искомой цифры. формат выходных данных выходной файл содержит искомую цифру. пример входных и выходных файлов task1.in task1.out 4 1 8 3

hellppp1 hellppp1    3   14.06.2019 20:30    1

Ответы
sogoyan2016 sogoyan2016  12.07.2020 09:23
Var k: integer;
  f: Text;
begin
  assign(f, 'Task1.in');
  reset(f);
  readln(f, k);
  close(f);
  assign(f, 'Task1.out');
  rewrite(f);
  
  if (k mod 2 = 0) then
    writeln(f, ((k-1) div 2) mod 10)
  else 
    write(f, (k div 2) div 10 + 1);

  close(f);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика

Популярные вопросы