tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Дано натуральное трехзначное
Дано натуральное трехзначное число n. составьте программу, выводящую четырехзначное число, полученное приписыванием цифры разряда единиц исходного числа к нему же слева (в разряд тысяч).
Maximus20161
2 10.06.2019 12:30
5
Ответы
LaSeine28
08.07.2020 21:19
Program Pr1;
uses crt;
var fl1,fl2:text;
n,tmp:string;
Begin
clrscr;
assign(fl1,'input.txt');
assign(fl2,'output.txt');
reset(fl1);
readln(fl1,n);
close(fl1);
tmp:=copy(n,length(n),1);
n:=tmp+n;
rewrite(fl2);
writeln(fl2,n);
close(fl2);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
aleshkaaaa1
04.05.2021 10:37
Напишите код для вызова персонажа... - рисование фигур и линий....
Cet31072007
10.04.2020 11:22
Я не шарю в информатике нужен ответ и объяснение....
chipolino555
24.11.2020 20:17
Информатика, для знающих вроде несложно. (блок схему составить на бумаге, в виде схемы)...
shubina021
30.07.2020 11:22
26)Константа null определена в залоговочном файле: A)include.h B)stdio.h C)alloc.h D)stdlib.h 27)Инициализация данных в с++ представляет собой: A)поиск данных переменной B)проверка...
Сач16
31.07.2020 11:31
Как пройти 6задание в практикуне. Нужна написать на языке Python у вас 8 новых сообщений. ...
szhanibekov
14.05.2020 16:58
Покорения каких племён, живших на левом берегу Дунай, изображено на рельефах колонны, построенной на Форуме?...
JHOOOOOOPE
14.05.2020 16:58
Напишите письмо, используя вводные слова, вводные предложения и вставные конструкции (не менее 12 предложений)....
ivankamartynyk
14.05.2020 16:58
В магазин завезли 899 кг кабачков. Первый покупатель взял для соления 3 % от всех кабачков, а второй — 1 % от всех кабачков. Сколько килограммов кабачков купил каждый из них Первый...
Fefiego
14.05.2020 16:58
Как влияет малая группа на развитие и становление человека? Дайте развёрнутый ответ...
Криш7771
14.05.2020 16:58
Чему ровно выражение (-4,3-1,2):(-1ц 7/25)=?...
Популярные вопросы
7. В классе 34 учеников. После уроков 16 пошли играть баскетбол, в 2 раза меньше...
1
Задание: напишите эссе на одну из предложенных тем. Объем письменной работы – 120...
3
сор литят 2 папугая один зеленый другой на север сколька будет стойть килограм...
2
Қатты керек болып тұр нужно...
1
соч по русскому языку 2 задание...
2
Упростите выражение V12 + 5V27 - V48...
2
записать в тетрадях название лабораторной работы, необходимые принадлежности и...
3
Прощание с матерьёй основная мысль текста...
1
15:x=y:4пропорциясы берилген болса х-у менин табыныз...
3
b)7*7*7*7*7*7*7*7=7*8 c)7*7*7*7*7*7*7*7=7 d)7*7*7*7*7*7*7*7=8:7...
3
uses crt;
var fl1,fl2:text;
n,tmp:string;
Begin
clrscr;
assign(fl1,'input.txt');
assign(fl2,'output.txt');
reset(fl1);
readln(fl1,n);
close(fl1);
tmp:=copy(n,length(n),1);
n:=tmp+n;
rewrite(fl2);
writeln(fl2,n);
close(fl2);
end.