Дано натуральное двузначное число. составить программу определения, является ли сумма его цифр двузначным числом. если нет, то через сколько чисел встретиться первое двузначное число, удовлетворяющее этому условию.на паскале

111110098735280 111110098735280    2   02.10.2019 13:00    11

Ответы
AndHeAgaIN2 AndHeAgaIN2  09.10.2020 11:48

var

x,x1:integer;

begin

readln(x);

if (x div 10 + x mod 10 >= 10) then writeln ('Является')

else begin  x1:=x; while (x1 div 10 + x1 mod 10 < 10) do x1:=x1+1; end;a

if (x div 10 + x mod 10 < 10) then writeln('Нужно увеличить на ',x1-x);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика