Дано натуральное число n( трехзначное ) составить программу которая вычисляет сумму цифр этого числа

superillarion15 superillarion15    3   06.07.2019 01:10    0

Ответы
прошу28 прошу28  29.07.2020 11:49
Код на Паскале:
Program proba;
Uses crt;
Var n,s:integer;
Begin
writeln('введите натуральное число');
Readln(n);
s:=0;
repeat s:=s+n mod 10;  
 n:=n div 10;until n=0;
writeln('сумма цифр ',s);
end.
P.S. Программа вычисляет не только трехзначные числа ;)
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика